Payment Express
All Systems Operational

Updated a few seconds ago

Hosted Payments API




Operational

Merchant Hosted API




Operational

Card Present Services




Operational

Batch Processing Services




Operational

IVR Payment Services




Operational

Payline Web Interface and Reporting




Operational

Banks and Acquirers




Operational

Scheduled Maintenance

Schedule

June 18, 2018 9:00PM - 9:30PM UTC

Components

Hosted Payments API, Merchant Hosted API, Card Present Services, Batch Processing Services, IVR Payment Services, Payline Web Interface and Reporting

Locations

Americas, Asia-Pacific, EMEA

Description

Updated on 16 April 2018 - Rescheduled Local times: NZT: 19 Jun 2018 at 09:00 PDT: 18 Jun 2018 at 14:00 AEST: 19 Jun 2018 at 07:00 Payment Express will disable the TLS1.0 and TLS1.1 HTTPS protocols. TLS 1.2 will be required. This is a highly critical change, merchants who have not updated their servers and integrations with TLS1.2 support will be unable to connect to Payment Express services Please refer to our security roadmap, where we have also prepared guides to assist merchants and their technical teams in preparation for this update: paymentexpress.com/security-roadmap

History

No incidents in the last 7 days